What’s Vulnerable › Vulnerabilities
CVE-2024-5327: PowerPack Addons for Elementor (Free Widgets, Extensions and Templates) <= 2.7.19 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The PowerPack Addons for Elementor (Free Widgets, Extensions and Templates) plugin for WordPress is vulnerable to DOM-Based Stored Cross-Site Scripting via the ‘pp_animated_gradient_bg_color’ parameter in all versions up to, and including, 2.7.19 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- ideaboxcreations PowerPack Addons for Elementor (Free Widgets, Extensions and Templates): before 2.7.20 — fixed in 2.7.20
How to fix
Upgrade to a fixed version: ideaboxcreations PowerPack Addons for Elementor (Free Widgets, Extensions and Templates) 2.7.20. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/powerpack-lite-for-elementor/tags/2.7.19/extensions/animated-gradient-background.php#L322
- https://plugins.trac.wordpress.org/changeset/3094253/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5618fdfc-636f-452b-80e1-5182b068d1c6?source=cve
- https://plugins.trac.wordpress.org/browser/powerpack-lite-for-elementor/tags/2.7.19/extensions/animated-gradient-background.php#L322
- https://plugins.trac.wordpress.org/changeset/3094253/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5618fdfc-636f-452b-80e1-5182b068d1c6?source=cve
Get alerted when CVE-2024-5327 or the next vulnerability affects your stack