What’s Vulnerable › Vulnerabilities
CVE-2024-53271: HTTP/1.1 multiple issues with envoy.reloadable_features.http1_balsa_delay_reset in envoy
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-18 · updated 2026-06-17
- Weakness: CWE-670
Description
Envoy is a cloud-native high-performance edge/middle/service proxy. In affected versions envoy does not properly handle http 1.1 non-101 1xx responses. This can lead to downstream failures in networked devices. This issue has been addressed in versions 1.31.5 and 1.32.3. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- envoyproxy envoy: from 1.31.0 before 1.31.5; from 1.32.0 through 1.32.3 — fixed in 1.31.5
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.31.5. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/commit/da56f6da63079baecef9183436ee5f4141a59af8
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-rmm5-h2wv-mg4f
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-rmm5-h2wv-mg4f
Get alerted when CVE-2024-53271 or the next vulnerability affects your stack