What’s Vulnerable › Vulnerabilities
CVE-2024-53277: Cross-site Scripting in form messages in silverstripe framework
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Silverstripe Framework is a PHP framework which powers the Silverstripe CMS. In some cases, form messages can contain HTML markup. This is an intentional feature, allowing links and other relevant HTML markup for the given message. Some form messages include content that the user can provide. There are scenarios in the CMS where that content doesn't get correctly sanitised prior to being included in the form message, resulting in an XSS vulnerability. This issue has been addressed in silverstripe/framework version 5.3.8 and users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- silverstripe-framework: before 5.3.8 — fixed in 5.3.8
How to fix
Upgrade to a fixed version: silverstripe-framework 5.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/silverstripe/silverstripe-framework/commit/74904f539347b7d1f8c5b5fb9e28d62ff251ee00
- https://github.com/silverstripe/silverstripe-framework/security/advisories/GHSA-ff6q-3c9c-6cf5
- https://www.silverstripe.org/download/security-releases/cve-2024-53277
Get alerted when CVE-2024-53277 or the next vulnerability affects your stack