What’s Vulnerable › Vulnerabilities
CVE-2024-53299: Apache Wicket: An attacker can intentionally trigger a memory leak
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-23 · updated 2026-06-17
- Weakness: CWE-400
Description
The request handling in the core in Apache Wicket 7.0.0 on any platform allows an attacker to create a DOS via multiple requests to server resources. Users are recommended to upgrade to versions 9.19.0 or 10.3.0, which fixes this issue.
Affected products
- Apache Software Foundation Apache Wicket: from 7.0.0 through 7.18.0; from 8.0.0 through 8.16.0; from 9.0.0 before 9.19.0; from 10.0.0 before 10.3.0 — fixed in 10.3.0, 9.19.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Wicket 10.3.0, 9.19.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/gyp2ht00c62827y0379lxh5dbx3hhho5
- http://www.openwall.com/lists/oss-security/2025/01/22/12
Get alerted when CVE-2024-53299 or the next vulnerability affects your stack