What’s Vulnerable › Vulnerabilities
CVE-2024-5330: Breakdance <= 1.7.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Breakdance plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the breakdance_css_file_paths_cache parameter in all versions up to, and including, 1.7.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Breakdance: before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: Breakdance 2.0. Check the vendor advisory for mitigations.
References
- https://breakdance.com/breakdance-2-0-now-available/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9dbd26f5-b75e-41a3-aefb-d6c8cc2cec7b?source=cve
Get alerted when CVE-2024-5330 or the next vulnerability affects your stack