What’s Vulnerable › Vulnerabilities
CVE-2024-5333: The Events Calendar < 6.8.2.1 - Unauthenticated Password Protected Event Disclosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-16 · updated 2026-06-17
Description
The Events Calendar WordPress plugin before 6.8.2.1 is missing access checks in the REST API, allowing for unauthenticated users to access information about password protected events.
Affected products
- stellarwp The Events Calendar: before 6.8.2.1 — fixed in 6.8.2.1
How to fix
Upgrade to a fixed version: stellarwp The Events Calendar 6.8.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-5333 or the next vulnerability affects your stack