What’s Vulnerable › Vulnerabilities
CVE-2024-5335: Ultimate Store Kit Elementor Addons, Woocommerce Builder, EDD Builder, Elementor Store Builder, Product Grid, Product Table, Woocommerce Slider <= 1.6.4 - Unauthenticated PHP Object Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-21 · updated 2026-06-17
- Weakness: CWE-502
Description
The Ultimate Store Kit Elementor Addons, Woocommerce Builder, EDD Builder, Elementor Store Builder, Product Grid, Product Table, Woocommerce Slider plugin is vulnerable to PHP Object Injection via deserialization of untrusted input via the _ultimate_store_kit_compare_products cookie in versions up to , and including, 1.6.4. This makes it possible for an unauthenticated attacker to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker or above to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- bdthemes Ultimate Store Kit Elementor Addons: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: bdthemes Ultimate Store Kit Elementor Addons 2.0.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ultimate-store-kit/trunk/includes/helper.php#L1103
- https://plugins.trac.wordpress.org/changeset/3135472/ultimate-store-kit/trunk/includes/helper.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2ae44bcb-6149-4661-8890-23c867e9a918?source=cve
Get alerted when CVE-2024-5335 or the next vulnerability affects your stack