What’s Vulnerable › Vulnerabilities
CVE-2024-53376
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-16 · updated 2026-06-17
- Weakness: CWE-78
Description
CyberPanel before 2.3.8 allows remote authenticated users to execute arbitrary commands via shell metacharacters in the phpSelection field to the websites/submitWebsiteCreation URI.
Affected products
- usmannasir cyberpanel: before 2.3.8 — fixed in 2.3.8
How to fix
Upgrade to a fixed version: usmannasir cyberpanel 2.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/ThottySploity/CVE-2024-53376
- https://github.com/ThottySploity/CVE-2024-53376/blob/aa306187323bd1127d56803cb34cac8820b61484/cyberpanel.py#L70
- https://thottysploity.github.io/posts/cve-2024-53376
- https://github.com/ThottySploity/CVE-2024-53376
Get alerted when CVE-2024-53376 or the next vulnerability affects your stack