What’s Vulnerable › Vulnerabilities
CVE-2024-5347: Happy Addons for Elementor <= 3.10.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Post Navigation Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-31 · updated 2026-06-17
- Weakness: CWE-79
Description
The Happy Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'arrow' attribute within the plugin's Post Navigation widget in all versions up to, and including, 3.10.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- thehappymonster Happy Addons for Elementor: before 3.11.0 — fixed in 3.11.0
How to fix
Upgrade to a fixed version: thehappymonster Happy Addons for Elementor 3.11.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/happy-elementor-addons/tags/3.10.9/widgets/post-navigation/widget.php#L588
- https://plugins.trac.wordpress.org/changeset/3095128/happy-elementor-addons/trunk/widgets/post-navigation/widget.php
- https://wordpress.org/plugins/happy-elementor-addons/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/415a7201-bdff-4342-9e06-ce0e500cdc7c?source=cve
- https://plugins.trac.wordpress.org/browser/happy-elementor-addons/tags/3.10.9/widgets/post-navigation/widget.php#L588
- https://plugins.trac.wordpress.org/changeset/3095128/happy-elementor-addons/trunk/widgets/post-navigation/widget.php
- https://wordpress.org/plugins/happy-elementor-addons/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/415a7201-bdff-4342-9e06-ce0e500cdc7c?source=cve
Get alerted when CVE-2024-5347 or the next vulnerability affects your stack