What’s Vulnerable › Vulnerabilities
CVE-2024-53678: Apache VCL: SQL injection vulnerability in New Block Allocation form
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache VCL. Users can modify form data submitted when requesting a new Block Allocation such that a SELECT SQL statement is modified. The data returned by the SELECT statement is not viewable by the attacker. This issue affects all versions of Apache VCL from 2.2 through 2.5.1. Users are recommended to upgrade to version 2.5.2, which fixes the issue.
Affected products
- Apache VCL: from 2.2 before 2.5.2 — fixed in 2.5.2
How to fix
Upgrade to a fixed version: Apache VCL 2.5.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/2bmjnzgjwwq59nv6xw44w0tnpz4k4pf4
- http://www.openwall.com/lists/oss-security/2025/03/24/1
Get alerted when CVE-2024-53678 or the next vulnerability affects your stack