What’s Vulnerable › Vulnerabilities
CVE-2024-53679: Apache VCL: XSS vulnerability in User Lookup impacting user privileges
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache VCL in the User Lookup form. A user with sufficient rights to be able to view this part of the site can craft a URL or be tricked in to clicking a URL that will give a specified user elevated rights. This issue affects all versions of Apache VCL through 2.5.1. Users are recommended to upgrade to version 2.5.2, which fixes the issue.
Affected products
- Apache VCL: from 2.1 before 2.5.2 — fixed in 2.5.2
How to fix
Upgrade to a fixed version: Apache VCL 2.5.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/bq5vs0hndt9cz9b6rpfr5on1nd4qrmyr
- http://www.openwall.com/lists/oss-security/2025/03/24/2
Get alerted when CVE-2024-53679 or the next vulnerability affects your stack