What’s Vulnerable › Vulnerabilities
CVE-2024-53681: nvmet: Don't overflow subsysnqn
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-15 · updated 2026-06-17
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: nvmet: Don't overflow subsysnqn nvmet_root_discovery_nqn_store treats the subsysnqn string like a fixed size buffer, even though it is dynamically allocated to the size of the string. Create a new string with kstrndup instead of using the old buffer.
Affected products
- Linux kernel: from 6.9.1 before 6.12.9; 6.9, 6.9-rc3, 6.9-rc4, 6.9-rc5, 6.9-rc6, 6.9-rc7 (+5) — fixed in 6.12.9
How to fix
Upgrade to a fixed version: Linux kernel 6.12.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4db3d750ac7e894278ef1cb1c53cc7d883060496
- https://git.kernel.org/stable/c/86645d8d062af3fdcbdaa0a289b95de55bca827d
Get alerted when CVE-2024-53681 or the next vulnerability affects your stack