What’s Vulnerable › Vulnerabilities
CVE-2024-53703
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-05 · updated 2026-06-17
- Weakness: CWE-121
Description
A vulnerability in the SonicWall SMA100 SSLVPN firmware 10.2.1.13-72sv and earlier versions mod_httprp library loaded by the Apache web server allows remote attackers to cause Stack-based buffer overflow and potentially lead to code execution.
Affected products
- SonicWall Sma 200 Firmware: before 10.2.1.14-75sv — fixed in 10.2.1.14-75sv
- SonicWall Sma 210 Firmware: before 10.2.1.14-75sv — fixed in 10.2.1.14-75sv
- SonicWall Sma 400 Firmware: before 10.2.1.14-75sv — fixed in 10.2.1.14-75sv
- SonicWall Sma 410 Firmware: before 10.2.1.14-75sv — fixed in 10.2.1.14-75sv
- SonicWall Sma 500V Firmware: before 10.2.1.14-75sv — fixed in 10.2.1.14-75sv
How to fix
Upgrade to a fixed version: SonicWall Sma 200 Firmware 10.2.1.14-75sv; SonicWall Sma 210 Firmware 10.2.1.14-75sv; SonicWall Sma 400 Firmware 10.2.1.14-75sv; SonicWall Sma 410 Firmware 10.2.1.14-75sv; SonicWall Sma 500V Firmware 10.2.1.14-75sv. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-53703 or the next vulnerability affects your stack