What’s Vulnerable › Vulnerabilities
CVE-2024-53821: WordPress Pie Register Premium plugin < 3.8.3.3 - Cross Site Scripting (XSS) vulnerability
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Genetech Pie Register Premium allows Reflected XSS.This issue affects Pie Register Premium: from n/a before 3.8.3.3.
Affected products
- Genetech Pie Register Premium: before 3.8.3.3 — fixed in 3.8.3.3
How to fix
Upgrade to a fixed version: Genetech Pie Register Premium 3.8.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-53821 or the next vulnerability affects your stack