What’s Vulnerable › Vulnerabilities
CVE-2024-53847: Trix vulnerable to Cross-site Scripting on copy & paste
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.
Affected products
- basecamp trix: from 2.0.0, < 2.1.9; from 1.0.0, < 1.3.3
References
- https://github.com/basecamp/trix/commit/272c7e27e722608732a67108ad3fe7870e233ac8
- https://github.com/basecamp/trix/security/advisories/GHSA-6vx4-v2jw-qwqh
Get alerted when CVE-2024-53847 or the next vulnerability affects your stack