What’s Vulnerable › Vulnerabilities
CVE-2024-53851: Partial denial of service via inline oneboxes in Discourse
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is an open source platform for community discussion. In affected versions the endpoint for generating inline oneboxes for URLs wasn't enforcing limits on the number of URLs that it accepted, allowing a malicious user to inflict denial of service on some parts of the app. This vulnerability is only exploitable by authenticated users. This issue has been patched in the latest stable, beta and tests-passed versions of Discourse. Users are advised to upgrade. Users unable to upgrade should turn off the `enable inline onebox on all domains` site setting and remove all entries from the `allowed inline onebox domains` site setting.
Affected products
- discourse: before 3.3.3; before 3.4.0; 3.4.0-beta1, 3.4.0-beta2, 3.4.0-beta3 — fixed in 3.3.3, 3.4.0
How to fix
Upgrade to a fixed version: discourse 3.3.3, 3.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/416ec83ae57924d721e6e374f4cda78bd77a4599
- https://github.com/discourse/discourse/security/advisories/GHSA-49rv-574x-wgpc
Get alerted when CVE-2024-53851 or the next vulnerability affects your stack