What’s Vulnerable › Vulnerabilities
CVE-2024-53856: rPGP Panics on Malformed Untrusted Input
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-05 · updated 2026-06-17
- Weakness: CWE-130
Description
rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1.
Affected products
- rpgp: before 0.14.1
References
Get alerted when CVE-2024-53856 or the next vulnerability affects your stack