What’s Vulnerable › Vulnerabilities
CVE-2024-53857: rPGP Potential Resource Exhaustion when handling Untrusted Messages
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-05 · updated 2026-06-17
- Weakness: CWE-770
Description
rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows attackers to trigger resource exhaustion vulnerabilities in rpgp by providing crafted messages. This affects general message parsing and decryption with symmetric keys.
Affected products
- rpgp: before 0.14.1 — fixed in 0.14.1
How to fix
Upgrade to a fixed version: rpgp 0.14.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-53857 or the next vulnerability affects your stack