What’s Vulnerable › Vulnerabilities
CVE-2024-53866: pnpm vulnerable to no-script global cache poisoning via overrides / `ignore-scripts` evasion
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-10 · updated 2026-06-22
- Weakness: CWE-426
Description
The package manager pnpm prior to version 9.15.0 seems to mishandle overrides and global cache: Overrides from one workspace leak into npm metadata saved in global cache; npm metadata from global cache affects other workspaces; and installs by default don't revalidate the data (including on first lockfile generation). This can make workspace A (even running with `ignore-scripts=true`) posion global cache and execute scripts in workspace B. Users generally expect `ignore-scripts` to be sufficient to prevent immediate code execution on install (e.g. when the tree is just repacked/bundled without executing it). Here, that expectation is broken. Global state integrity is lost via operations that one would expect to be secure, enabling subsequently running arbitrary code execution on installs. Version 9.15.0 fixes the issue. As a work-around, use separate cache and store dirs in each workspace.
Affected products
- pnpm: before 9.15.0 — fixed in 9.15.0
How to fix
Upgrade to a fixed version: pnpm 9.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/pnpm/pnpm/commit/11afcddea48f25ed5117a87dc1780a55222b9743
- https://github.com/pnpm/pnpm/security/advisories/GHSA-vm32-9rqf-rh3r
Get alerted when CVE-2024-53866 or the next vulnerability affects your stack