What’s Vulnerable › Vulnerabilities
CVE-2024-53901
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-24 · updated 2026-06-17
- Weakness: CWE-787
Description
The Imager package before 1.025 for Perl has a heap-based buffer overflow leading to denial of service, or possibly unspecified other impact, when the trim() method is called on a crafted input image.
Affected products
- TONYC Imager: before 1.025 — fixed in 1.025
How to fix
Upgrade to a fixed version: TONYC Imager 1.025. Check the vendor advisory for mitigations.
References
- https://github.com/briandfoy/cpan-security-advisory/issues/167
- https://github.com/briandfoy/cpan-security-advisory/issues/171
- https://github.com/tonycoz/imager/issues/534
- https://metacpan.org/release/TONYC/Imager-1.025/changes
Get alerted when CVE-2024-53901 or the next vulnerability affects your stack