What’s Vulnerable › Vulnerabilities
CVE-2024-53907
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-06 · updated 2026-06-17
- Weakness: CWE-770
Description
An issue was discovered in Django 5.1 before 5.1.4, 5.0 before 5.0.10, and 4.2 before 4.2.17. The strip_tags() method and striptags template filter are subject to a potential denial-of-service attack via certain inputs containing large sequences of nested incomplete HTML entities.
Affected products
- Django: from 4.2 before 4.2.17; from 5.0 before 5.0.10; from 5.1 before 5.1.4 — fixed in 4.2.17, 5.0.10, 5.1.4
How to fix
Upgrade to a fixed version: Django 4.2.17, 5.0.10, 5.1.4. Check the vendor advisory for mitigations.
References
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/g/django-announce
- https://www.openwall.com/lists/oss-security/2024/12/04/3
- https://lists.debian.org/debian-lts-announce/2024/12/msg00028.html
Get alerted when CVE-2024-53907 or the next vulnerability affects your stack