What’s Vulnerable › Vulnerabilities
CVE-2024-53920
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-27 · updated 2026-09-21
- Weakness: CWE-94
Description
In elisp-mode.el in GNU Emacs before 30.1, a user who chooses to invoke elisp-completion-at-point (for code completion) on untrusted Emacs Lisp source code can trigger unsafe Lisp macro expansion that allows attackers to execute arbitrary code. (This unsafe expansion also occurs if a user chooses to enable on-the-fly diagnosis that byte compiles untrusted Emacs Lisp source code.)
Affected products
- GNU Emacs: before 30.1 — fixed in 30.1
How to fix
Upgrade to a fixed version: GNU Emacs 30.1. Check the vendor advisory for mitigations.
References
- https://eshelyaron.com/posts/2024-11-27-emacs-aritrary-code-execution-and-how-to-avoid-it.html
- https://git.savannah.gnu.org/cgit/emacs.git/tag/?h=emacs-30.0.92
- https://git.savannah.gnu.org/cgit/emacs.git/tree/ChangeLog.4
- https://git.savannah.gnu.org/cgit/emacs.git/tree/etc/NEWS?h=emacs-30.1
- https://news.ycombinator.com/item?id=42256409
- https://yhetil.org/emacs/CAFXAjY5f4YfHAtZur1RAqH34UbYU56_t6t2Er0YEh1Sb7-W=hg@mail.gmail.com/
- http://www.openwall.com/lists/oss-security/2026/08/20/3
- http://www.openwall.com/lists/oss-security/2026/08/20/7
- http://www.openwall.com/lists/oss-security/2026/09/14/1
- http://www.openwall.com/lists/oss-security/2026/09/21/9
- https://lists.debian.org/debian-lts-announce/2025/02/msg00033.html
Get alerted when CVE-2024-53920 or the next vulnerability affects your stack