What’s Vulnerable › Vulnerabilities
CVE-2024-53947: Apache Superset: Improper SQL authorisation, parse not checking for specific postgres functions
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-09 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Superset. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. This issue is a follow-up to CVE-2024-39887 with additional disallowed PostgreSQL functions now included: query_to_xml_and_xmlschema, table_to_xml, table_to_xml_and_xmlschema. This issue affects Apache Superset: <4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue or add these Postgres functions to the config set DISALLOWED_SQL_FUNCTIONS.
Affected products
- Apache Superset: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: Apache Superset 4.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-53947 or the next vulnerability affects your stack