What’s Vulnerable › Vulnerabilities
CVE-2024-53948: Apache Superset: Error verbosity exposes metadata in analytics databases
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-09 · updated 2026-06-17
- Weakness: CWE-209
Description
Generation of Error Message Containing analytics metadata Information in Apache Superset. This issue affects Apache Superset: before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
Affected products
- Apache Superset: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: Apache Superset 4.1.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/8howpf3png0wrgpls46ggk441oczlfvf
- http://www.openwall.com/lists/oss-security/2024/12/09/3
Get alerted when CVE-2024-53948 or the next vulnerability affects your stack