What’s Vulnerable › Vulnerabilities
CVE-2024-53949: Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-09 · updated 2026-06-17
- Weakness: CWE-863
Description
Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API. issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
Affected products
- Apache Superset: from 2.0.0 before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: Apache Superset 4.1.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/d3scbwmfpzbpm6npnzdw5y4owtqqyq8d
- http://www.openwall.com/lists/oss-security/2024/12/09/4
Get alerted when CVE-2024-53949 or the next vulnerability affects your stack