What’s Vulnerable › Vulnerabilities

CVE-2024-53956: Premiere Pro | Heap-based Buffer Overflow (CWE-122)

Description

Premiere Pro versions 25.0, 24.6.3 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Premiere 24.6.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-53956 or the next vulnerability affects your stack