What’s Vulnerable › Vulnerabilities
CVE-2024-53959: Adobe Framemaker | Stack-based Buffer Overflow (CWE-121)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-10 · updated 2026-06-17
- Weakness: CWE-121
Description
Adobe Framemaker versions 2020.7, 2022.5 and earlier are affected by a Stack-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Framemaker: before 2020.7; from 2022 before 2022.5 — fixed in 2020.7, 2022.5
How to fix
Upgrade to a fixed version: Adobe Framemaker 2020.7, 2022.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-53959 or the next vulnerability affects your stack