What’s Vulnerable › Vulnerabilities
CVE-2024-5401
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-04 · updated 2026-09-26
- Weakness: CWE-913
Description
Improper control of dynamically-managed code resources vulnerability in WebAPI component in Synology DiskStation Manager (DSM) before 7.1.1-42962-8 and 7.2.1-69057-2 and 7.2.2-72806 and Synology Unified Controller (DSMUC) before 3.1.4-23079 allows remote authenticated users to obtain privileges without consent via unspecified vectors.
Affected products
- Synology DiskStation Manager: from 7.2.1-69057 before 7.2.1-69057-2; from 7.2.2-72803 before 7.2.2-72806 — fixed in 7.2.1-69057-2, 7.2.2-72806
- Synology Diskstation Manager Unified Controller: from 3.1-23028 before 3.1.4-23079 — fixed in 3.1.4-23079
How to fix
Upgrade to a fixed version: Synology DiskStation Manager 7.2.1-69057-2, 7.2.2-72806; Synology Diskstation Manager Unified Controller 3.1.4-23079. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-5401 or the next vulnerability affects your stack