What’s Vulnerable › Vulnerabilities
CVE-2024-54016: compression bomb attack in Apache Seata Server
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-409
Description
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Seata (incubating). This issue affects Apache Seata (incubating): through <=2.2.0. Users are recommended to upgrade to version 2.3.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Seata (incubating): from 2.0.0 before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Seata (incubating) 2.3.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/grn0x8tmssx07qc9z50lwgmrkwzrrhzg
- http://www.openwall.com/lists/oss-security/2025/03/19/6
Get alerted when CVE-2024-54016 or the next vulnerability affects your stack