What’s Vulnerable › Vulnerabilities
CVE-2024-54024
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-78
Description
An improper neutralization of special elements used in an OS command ('OS Command Injection') vulnerability [CWE-78] in Fortinet FortiIsolator before version 2.4.6 allows a privileged attacker with super-admin profile and CLI access to execute unauthorized code via specifically crafted HTTP requests.
Affected products
- Fortinet FortiIsolator: from 2.4.3 before 2.4.7 — fixed in 2.4.7
How to fix
Upgrade to a fixed version: Fortinet FortiIsolator 2.4.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-54024 or the next vulnerability affects your stack