What’s Vulnerable › Vulnerabilities

CVE-2024-54037: Adobe Connect | Cross-site Scripting (DOM-based XSS) (CWE-79)

Description

Adobe Connect versions 12.6, 11.4.7 and earlier are affected by a DOM-based Cross-Site Scripting (XSS) vulnerability that could be exploited by an attacker to execute arbitrary code in the context of the victim's browser session. By manipulating a DOM element through a crafted URL or user input, the high-privileged attacker can inject malicious scripts that run when the page is rendered. This type of attack requires user interaction, as the victim would need to visit a malicious link or input data into a compromised form. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality and integrity impact as high.

Affected products

How to fix

Upgrade to a fixed version: Adobe Connect 11.4.9, 12.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-54037 or the next vulnerability affects your stack