What’s Vulnerable › Vulnerabilities
CVE-2024-54141: phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-06 · updated 2026-06-17
- Weakness: CWE-209
Description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Prior to 4.0.0, phpMyFAQ exposes the database (ie postgreSQL) server's credential when connection to DB fails. This vulnerability is fixed in 4.0.0.
Affected products
- thorsten phpMyFAQ: 4.0.0-alpha
References
- https://github.com/thorsten/phpMyFAQ/commit/b9289a0b2233df864361c131cd177b6715fbb0fe
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-vrjr-p3xp-xx2x
Get alerted when CVE-2024-54141 or the next vulnerability affects your stack