What’s Vulnerable › Vulnerabilities
CVE-2024-54145: Cacti has a SQL Injection vulnerability when request automation devices
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-89
Description
Cacti is an open source performance and fault management framework. Cacti has a SQL injection vulnerability in the get_discovery_results function of automation_devices.php using the network parameter. This vulnerability is fixed in 1.2.29.
Affected products
- cacti: before 1.2.29 — fixed in 1.2.29
How to fix
Upgrade to a fixed version: cacti 1.2.29. Check the vendor advisory for mitigations.
References
- https://github.com/Cacti/cacti/commit/c7e4ee798d263a3209ae6e7ba182c7b65284d8f0
- https://github.com/Cacti/cacti/security/advisories/GHSA-fh3x-69rr-qqpp
- https://lists.debian.org/debian-lts-announce/2025/02/msg00010.html
Get alerted when CVE-2024-54145 or the next vulnerability affects your stack