What’s Vulnerable › Vulnerabilities
CVE-2024-54146: Cacti has a SQL Injection vulnerability when view host template
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 46.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-89
Description
Cacti is an open source performance and fault management framework. Cacti has a SQL injection vulnerability in the template function of host_templates.php using the graph_template parameter. This vulnerability is fixed in 1.2.29.
Affected products
- cacti: before 1.2.29 — fixed in 1.2.29
How to fix
Upgrade to a fixed version: cacti 1.2.29. Check the vendor advisory for mitigations.
References
- https://github.com/Cacti/cacti/commit/c7e4ee798d263a3209ae6e7ba182c7b65284d8f0
- https://github.com/Cacti/cacti/security/advisories/GHSA-vj9g-p7f2-4wqj
Get alerted when CVE-2024-54146 or the next vulnerability affects your stack