What’s Vulnerable › Vulnerabilities
CVE-2024-54148: Gogs has a Path Traversal in file editing UI
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-23 · updated 2026-06-17
- Weakness: CWE-22
Description
Gogs is an open source self-hosted Git service. A malicious user is able to commit and edit a crafted symlink file to a repository to gain SSH access to the server. The vulnerability is fixed in 0.13.1.
Affected products
- gogs: before 0.13.1 — fixed in 0.13.1
How to fix
Upgrade to a fixed version: gogs 0.13.1. Check the vendor advisory for mitigations.
References
- https://github.com/gogs/gogs/commit/c94baec9ca923f38c19f0c7c5af722b9ec04022a
- https://github.com/gogs/gogs/issues/7582
- https://github.com/gogs/gogs/pull/7857
- https://github.com/gogs/gogs/security/advisories/GHSA-r7j8-5h9c-f6fx
Get alerted when CVE-2024-54148 or the next vulnerability affects your stack