What’s Vulnerable › Vulnerabilities
CVE-2024-5417: Gutentor < 3.3.6 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gutentor WordPress plugin before 3.3.6 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Gutentor: before 3.3.6 — fixed in 3.3.6
How to fix
Upgrade to a fixed version: Gutentor 3.3.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-5417 or the next vulnerability affects your stack