What’s Vulnerable › Vulnerabilities
CVE-2024-54173: IBM MQ information disclosure
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-28 · updated 2026-06-17
- Weakness: CWE-1323
Description
IBM MQ 9.3 LTS, 9.3 CD, 9.4 LTS, and 9.4 CD reveals potentially sensitive information in trace files that could be read by a local user when webconsole trace is enabled.
Affected products
- IBM MQ Appliance: before 9.4.2; from 9.3.0.0 before 9.3.0.27; from 9.4.0.0 before 9.4.0.10 — fixed in 9.3.0.27, 9.4.0.10, 9.4.2
How to fix
Upgrade to a fixed version: IBM MQ Appliance 9.3.0.27, 9.4.0.10, 9.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-54173 or the next vulnerability affects your stack