What’s Vulnerable › Vulnerabilities
CVE-2024-5419: Void Contact Form 7 Widget For Elementor Page Builder <= 2.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via cf7_redirect_page Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Void Contact Form 7 Widget For Elementor Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'cf7_redirect_page' attribute within the plugin's Void Contact From 7 widget in all versions up to, and including, 2.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- voidCoders Void Contact Form 7 Widget For Elementor Page Builder: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: voidCoders Void Contact Form 7 Widget For Elementor Page Builder 2.4.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/cf7-widget-elementor/tags/2.4/widgets/void-section-cf7.php#L1672
- https://plugins.trac.wordpress.org/changeset/3109802/#file6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2837c9b2-419e-453a-b011-5ec1ef050d62?source=cve
- https://plugins.trac.wordpress.org/browser/cf7-widget-elementor/tags/2.4/widgets/void-section-cf7.php#L1672
- https://plugins.trac.wordpress.org/changeset/3109802/#file6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2837c9b2-419e-453a-b011-5ec1ef050d62?source=cve
Get alerted when CVE-2024-5419 or the next vulnerability affects your stack