What’s Vulnerable › Vulnerabilities
CVE-2024-54314: WordPress Primary Addon for Elementor plugin <= 1.6.0 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in nicheaddons Primary Addon for Elementor primary-addon-for-elementor allows Stored XSS.This issue affects Primary Addon for Elementor: from n/a through <= 1.6.0.
Affected products
- nicheaddons Primary Addon for Elementor: before 1.6.2 — fixed in 1.6.2
How to fix
Upgrade to a fixed version: nicheaddons Primary Addon for Elementor 1.6.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-54314 or the next vulnerability affects your stack