What’s Vulnerable › Vulnerabilities
CVE-2024-5435: Generation of Error Message Containing Sensitive Information in GitLab
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-12 · updated 2026-06-17
- Weakness: CWE-209
Description
An issue has been discovered discovered in GitLab EE/CE affecting all versions starting from 15.10 before 17.1.7, all versions starting from 17.2 before 17.2.5, all versions starting from 17.3 before 17.3.2 will disclose user password from repository mirror configuration.
Affected products
- GitLab: from 15.10.0 before 17.1.7; from 17.2.0 before 17.2.5; from 17.3.0 before 17.3.2 — fixed in 17.1.7, 17.2.5, 17.3.2
How to fix
Upgrade to a fixed version: GitLab 17.1.7, 17.2.5, 17.3.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/464044
- https://hackerone.com/reports/2520722
- https://about.gitlab.com/releases/2024/09/11/patch-release-gitlab-17-3-2-released/
Get alerted when CVE-2024-5435 or the next vulnerability affects your stack