What’s Vulnerable › Vulnerabilities
CVE-2024-5436: Type Confusion in Snapchat Lenscore
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-31 · updated 2026-06-17
- Weakness: CWE-704
Description
Type confusion in Snapchat LensCore could lead to denial of service or arbitrary code execution prior to version 12.88. We recommend upgrading to version 12.88 or above.
Affected products
- Snapchat Lenscore: before 12.88 — fixed in 12.88
How to fix
Upgrade to a fixed version: Snapchat Lenscore 12.88. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-5436 or the next vulnerability affects your stack