What’s Vulnerable › Vulnerabilities
CVE-2024-5439: Blocksy <= 2.0.50 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-05 · updated 2026-06-17
- Weakness: CWE-20
Description
The Blocksy theme for WordPress is vulnerable to Reflected Cross-Site Scripting via the custom_url parameter in all versions up to, and including, 2.0.50 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- creativethemeshq Blocksy: before 2.0.51 — fixed in 2.0.51
How to fix
Upgrade to a fixed version: creativethemeshq Blocksy 2.0.51. Check the vendor advisory for mitigations.
References
- https://themes.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=229705%40blocksy%2F2.0.51&old=228990%40blocksy%2F2.0.50
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c05687f4-5ea2-4226-982f-c3499f204685?source=cve
- https://themes.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=229705%40blocksy%2F2.0.51&old=228990%40blocksy%2F2.0.50
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c05687f4-5ea2-4226-982f-c3499f204685?source=cve
Get alerted when CVE-2024-5439 or the next vulnerability affects your stack