What’s Vulnerable › Vulnerabilities
CVE-2024-5440: If-So Dynamic Content Personalization < 1.8.0.3 - Contributor+ Shortcode Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The If-So Dynamic Content Personalization WordPress plugin before 1.8.0.3 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- If So Plugin If-So Dynamic Content Personalization: before 1.8.0.3 — fixed in 1.8.0.3
How to fix
Upgrade to a fixed version: If So Plugin If-So Dynamic Content Personalization 1.8.0.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/52fdc271-96f2-4e25-9df2-29a3ce06328c/
- https://wpscan.com/vulnerability/52fdc271-96f2-4e25-9df2-29a3ce06328c/
Get alerted when CVE-2024-5440 or the next vulnerability affects your stack