What’s Vulnerable › Vulnerabilities
CVE-2024-5441: Modern Events Calendar <= 7.11.0 - Authenticated (Subscriber+) Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-434
Description
The Modern Events Calendar plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the set_featured_image function in all versions up to, and including, 7.11.0. This makes it possible for authenticated attackers, with subscriber access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The plugin allows administrators (via its settings) to extend the ability to submit events to unauthenticated users, which would allow unauthenticated attackers to exploit this vulnerability.
Affected products
- Webnus Modern Events Calendar: before 7.12.0 — fixed in 7.12.0
- Modern Events Calendar Lite: through 6.5.6
How to fix
Upgrade to a fixed version: Webnus Modern Events Calendar 7.12.0. Check the vendor advisory for mitigations.
References
- https://webnus.net/modern-events-calendar/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0c007090-9d9b-4ee7-8f77-91abd4373051?source=cve
- https://webnus.net/modern-events-calendar/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0c007090-9d9b-4ee7-8f77-91abd4373051?source=cve
Get alerted when CVE-2024-5441 or the next vulnerability affects your stack