What’s Vulnerable › Vulnerabilities
CVE-2024-54461: Unsanitized Filenames in Flutter package file_selector_android Allow File Overwrites
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-29 · updated 2026-06-17
- Weakness: CWE-23
Description
The file names constructed within file_selector are missing sanitization checks leaving them vulnerable to malicious document providers. This may result in cases where a user with a malicious document provider installed can select a document file from that provider while using your app and could potentially override internal files in your app cache. Issue patched in 0.5.1+12. It is recommended to update to the latest version of file_selector_android that contains the changes to address this vulnerability.
Affected products
- Flutter file_selector_android: from 0.5.1 before 0.5.1\+12 — fixed in 0.5.1\+12
How to fix
Upgrade to a fixed version: Flutter file_selector_android 0.5.1\+12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-54461 or the next vulnerability affects your stack