What’s Vulnerable › Vulnerabilities
CVE-2024-54515
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-281
Description
A logic issue was addressed with improved restrictions. This issue is fixed in macOS Sequoia 15.2. A malicious app may be able to gain root privileges.
Affected products
- Apple macOS: before 15.2 — fixed in 15.2
How to fix
Upgrade to a fixed version: Apple macOS 15.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-54515 or the next vulnerability affects your stack