What’s Vulnerable › Vulnerabilities
CVE-2024-54538
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-20 · updated 2026-06-17
- Weakness: CWE-770
Description
A denial-of-service issue was addressed with improved input validation. This issue is fixed in iOS 17.7.1 and iPadOS 17.7.1, iOS 18.1 and iPadOS 18.1, macOS Sequoia 15.1, macOS Sonoma 14.7.1, macOS Ventura 13.7.1, tvOS 18.1, visionOS 2.1, watchOS 11.1. A remote attacker may be able to cause a denial-of-service.
Affected products
- Apple iPadOS: before 17.7.1; from 18.0 before 18.1 — fixed in 17.7.1, 18.1
- Apple Iphone Os: before 17.7.1; from 18.0 before 18.1 — fixed in 17.7.1, 18.1
- Apple macOS: from 13.0 before 13.7.1; from 14.0 before 14.7.1 — fixed in 13.7.1, 14.7.1
- Apple tvOS: before 18.1 — fixed in 18.1
- Apple visionOS: before 2.1 — fixed in 2.1
- Apple watchOS: before 11.1 — fixed in 11.1
How to fix
Upgrade to a fixed version: Apple iPadOS 17.7.1, 18.1; Apple Iphone Os 17.7.1, 18.1; Apple macOS 13.7.1, 14.7.1; Apple tvOS 18.1; Apple visionOS 2.1; Apple watchOS 11.1. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/121563
- https://support.apple.com/en-us/121564
- https://support.apple.com/en-us/121565
- https://support.apple.com/en-us/121566
- https://support.apple.com/en-us/121567
- https://support.apple.com/en-us/121568
- https://support.apple.com/en-us/121569
- https://support.apple.com/en-us/121570
Get alerted when CVE-2024-54538 or the next vulnerability affects your stack