What’s Vulnerable › Vulnerabilities
CVE-2024-54676: Apache OpenMeetings: Deserialisation of untrusted data in cluster mode
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 68.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-502
Description
Vendor: The Apache Software Foundation Versions Affected: Apache OpenMeetings from 2.1.0 before 8.0.0 Description: Default clustering instructions at https://openmeetings.apache.org/Clustering.html doesn't specify white/black lists for OpenJPA this leads to possible deserialisation of untrusted data. Users are recommended to upgrade to version 8.0.0 and update their startup scripts to include the relevant 'openjpa.serialization.class.blacklist' and 'openjpa.serialization.class.whitelist' configurations as shown in the documentation.
Affected products
- Apache Software Foundation Apache OpenMeetings: from 2.1 before 8.0.0 — fixed in 8.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OpenMeetings 8.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/o0k05jxrt5tp4nm45lj14yfjxmg67m95
- http://www.openwall.com/lists/oss-security/2025/01/08/1
Get alerted when CVE-2024-54676 or the next vulnerability affects your stack