What’s Vulnerable › Vulnerabilities

CVE-2024-54677: Apache Tomcat: DoS in examples web application

Description

Uncontrolled Resource Consumption vulnerability in the examples web application provided with Apache Tomcat leads to denial of service. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.9.97. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 10.1.34, 11.0.2, 9.0.98. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-54677 or the next vulnerability affects your stack