What’s Vulnerable › Vulnerabilities

CVE-2024-5470: Improper Access Control in GitLab

Description

An issue was discovered in GitLab CE/EE affecting all versions starting from 17.0 prior to 17.0.4 and from 17.1 prior to 17.1.2 where a Guest user with `admin_push_rules` permission may have been able to create project-level deploy tokens.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.0.4, 17.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-5470 or the next vulnerability affects your stack